summaryrefslogtreecommitdiffstats
path: root/k8s/setup.py
diff options
context:
space:
mode:
authorLusheng Ji <lji@research.att.com>2018-03-23 19:21:59 +0000
committerGerrit Code Review <gerrit@onap.org>2018-03-23 19:21:59 +0000
commit7d9895ebb2ed0554ed8fafa5c909a9a930c3f962 (patch)
treee521755dea9fe4d32e66f3619f8beccedfc83121 /k8s/setup.py
parent8534af4f1ef5be3c6f946913824d5ed807e2321c (diff)
parent1ed29c111f50e33ac89915ba86b530820da3a689 (diff)
Merge "Add DCAE Kubernetes plugin"
Diffstat (limited to 'k8s/setup.py')
-rw-r--r--k8s/setup.py39
1 files changed, 39 insertions, 0 deletions
diff --git a/k8s/setup.py b/k8s/setup.py
new file mode 100644
index 0000000..f160777
--- /dev/null
+++ b/k8s/setup.py
@@ -0,0 +1,39 @@
+# ============LICENSE_START=======================================================
+# org.onap.dcae
+# ================================================================================
+# Copyright (c) 2017-2018 AT&T Intellectual Property. All rights reserved.
+# ================================================================================
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+# ============LICENSE_END=========================================================
+#
+# ECOMP is a trademark and service mark of AT&T Intellectual Property.
+
+from setuptools import setup
+
+setup(
+ name='k8splugin',
+ description='Cloudify plugin for containerized components deployed using Kubernetes',
+ version="1.0.0",
+ author='J. F. Lucas, Michael Hwang, Tommy Carpenter',
+ packages=['k8splugin','k8sclient','msb','configure'],
+ zip_safe=False,
+ install_requires=[
+ "python-consul>=0.6.0,<1.0.0",
+ "uuid==1.30",
+ "onap-dcae-dockering>=1.0.0,<2.0.0",
+ "onap-dcae-dcaepolicy-lib>=2.1.0,<3.0.0",
+ "cloudify-plugins-common==3.4",
+ "cloudify-python-importer==0.1.0",
+ "kubernetes==4.0.0"
+ ]
+)