summaryrefslogtreecommitdiffstats
path: root/cdap/pom.xml
diff options
context:
space:
mode:
authorAndrew Gauld <ag1282@att.com>2018-02-22 11:35:58 -0500
committerAndrew Gauld <ag1282@att.com>2018-02-22 11:36:31 -0500
commitb758d3686595c03eeb1bfe4f50b86f28b7b8c86f (patch)
treed39f5509e654f1756bd80853275b34b2cd2a6872 /cdap/pom.xml
parentbc19a3632f8df30e28876418f00cd96caa6dfa91 (diff)
Make SONAR code coverage work
Change-Id: I8a61f287d439a5bf0b2cb203e31b514a2cae0a5e Issue-ID: DCAEGEN2-355 Signed-off-by: Andrew Gauld <ag1282@att.com>
Diffstat (limited to 'cdap/pom.xml')
-rw-r--r--cdap/pom.xml11
1 files changed, 5 insertions, 6 deletions
diff --git a/cdap/pom.xml b/cdap/pom.xml
index 3fcbb4e..e0907c5 100644
--- a/cdap/pom.xml
+++ b/cdap/pom.xml
@@ -33,14 +33,13 @@ ECOMP is a trademark and service mark of AT&T Intellectual Property.
<properties>
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
- <!-- sonar -->
- <sonar.skip>true</sonar.skip>
<sonar.sources>cdapplugin/</sonar.sources>
- <sonar.junit.reportspath>cdapplugin/xunit-reports/xunit-result-cdapcloudify.xml</sonar.junit.reportspath>
- <sonar.python.coverage.reportpath>cdapplugin/coverage-reports/coverage-cdapcloudify.xml</sonar.python.coverage.reportpath>
+ <sonar.junit.reportspath>cdapplugin/xunit-results.xml</sonar.junit.reportspath>
+ <sonar.python.coverage.reportpath>cdapplugin/coverage.xml</sonar.python.coverage.reportpath>
<sonar.language>py</sonar.language>
- <sonar.pluginname>python</sonar.pluginname>
- <sonar.inclusions>*/cdapcloudify/**.py</sonar.inclusions>
+ <sonar.pluginname>Python</sonar.pluginname>
+ <sonar.inclusions>cdapcloudify/**/*.py</sonar.inclusions>
+ <sonar.exclusions>cdapcloudify/test/*,cdapcloudify/setup.py</sonar.exclusions>
</properties>
<build>
<finalName>${project.artifactId}-${project.version}</finalName>