summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorTommy Carpenter <tommy@research.att.com>2018-02-27 21:20:00 -0500
committerTommy Carpenter <tommy@research.att.com>2018-03-01 11:23:40 -0500
commit16841e4acee2cc31558bdaf618d68e4349c06168 (patch)
treea9bff5ca8af6256122cc0e406bac81f8fb6fba31 /setup.py
parent584b93a74f760beb51f973412a092533c838faeb (diff)
Add a new endpoint for getting arbitrary keys
Change-Id: I4888bf3c596bee72637a881830cef4835076bcb2 Issue-ID: DCAEGEN2-348 Signed-off-by: Tommy Carpenter <tommy@research.att.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py18
1 files changed, 8 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index 96f2718..2c4fd2e 100644
--- a/setup.py
+++ b/setup.py
@@ -16,21 +16,19 @@
#
# ECOMP is a trademark and service mark of AT&T Intellectual Property.
-import os
from setuptools import setup, find_packages
-from pip.req import parse_requirements
-from pip.download import PipSession
setup(
name='config_binding_service',
- version='2.0.0',
+ version='2.1.0',
packages=find_packages(exclude=["tests.*", "tests"]),
- author = "Tommy Carpenter",
- author_email = "tommy@research.att.com",
+ author="Tommy Carpenter",
+ author_email="tommy@research.att.com",
description='Service to fetch and bind configurations',
- license = "",
- keywords = "",
- url = "https://gerrit.onap.org/r/#/admin/projects/dcaegen2/platform/configbinding",
+ license="",
+ keywords="",
+ url="https://gerrit.onap.org/r/#/admin/projects/dcaegen2/platform/configbinding",
zip_safe=False,
- scripts = ["bin/run.py"]
+ scripts=["bin/run.py"],
+ install_requires=["requests", "Flask", "connexion", "six"]
)