summaryrefslogtreecommitdiffstats
path: root/oti/event-handler/setup.py
diff options
context:
space:
mode:
authorKotagiri, Ramprasad (rp5662) <rp5662@att.com>2019-12-19 17:41:16 -0500
committerKotagiri, Ramprasad (rp5662) <rp5662@att.com>2020-01-21 16:50:17 -0500
commit158b75abd6095a3155f5057832ec868bc99ced36 (patch)
treed374ba4adcfa6db9a036cb2bf018fe529c215eee /oti/event-handler/setup.py
parent77900bb3097491cd9fca964c111ea70724e53989 (diff)
Add OTI event-handler project
OTI event handler application in DCAEGEN2 platform Change-Id: Ie64f26f851e2045f00043f90279d503c2dc62948 Issue-ID: DCAEGEN2-1910 Signed-off-by: Kotagiri, Ramprasad (rp5662) <rp5662@att.com>
Diffstat (limited to 'oti/event-handler/setup.py')
-rw-r--r--oti/event-handler/setup.py46
1 files changed, 46 insertions, 0 deletions
diff --git a/oti/event-handler/setup.py b/oti/event-handler/setup.py
new file mode 100644
index 0000000..b2dd1a2
--- /dev/null
+++ b/oti/event-handler/setup.py
@@ -0,0 +1,46 @@
+# ================================================================================
+# Copyright (c) 2019-2020 AT&T Intellectual Property. All rights reserved.
+# ================================================================================
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+# ============LICENSE_END=========================================================
+
+"""DCAE-Controller dti_handler"""
+
+from setuptools import setup
+
+setup(
+ name='otihandler',
+ description='DCAE-Controller OTI Handler',
+ version="1.0.0",
+ author=[''],
+ packages=['otihandler'],
+ zip_safe=False,
+ install_requires=[
+ "CherryPy>=18.0.0",
+ "docker==4.1.0",
+ "enum34>=1.1.6",
+ "kubernetes==4.0.0",
+ "requests>=2.18.4,<3.0.0",
+ "SQLAlchemy==1.3.6",
+ "psycopg2-binary==2.8.4",
+ "pyOpenSSL==19.1.0",
+ "pycrypto==2.6.1",
+ "uuid==1.30"
+ ],
+ keywords='oti dcae controller',
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Intended Audience :: Developers',
+ 'Programming Language :: Python :: 3.6'
+ ]
+)