summaryrefslogtreecommitdiffstats
path: root/sshkeyshare/pom.xml
diff options
context:
space:
mode:
Diffstat (limited to 'sshkeyshare/pom.xml')
-rw-r--r--sshkeyshare/pom.xml13
1 files changed, 3 insertions, 10 deletions
diff --git a/sshkeyshare/pom.xml b/sshkeyshare/pom.xml
index 06fc8df..c3e6b6b 100644
--- a/sshkeyshare/pom.xml
+++ b/sshkeyshare/pom.xml
@@ -44,19 +44,12 @@ limitations under the License.
<typefile.dest>type_files/sshkeyshare/sshkey_types.yaml</typefile.dest>
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
<sonar.sources>.</sonar.sources>
- <!-- customize the SONARQUBE URL -->
- <sonar.host.url>http://localhost:9000</sonar.host.url>
- <!-- below are language dependent -->
- <!-- for Python -->
+ <sonar.junit.reportsPath>xunit-results.xml</sonar.junit.reportsPath>
+ <sonar.python.coverage.reportPath>coverage.xml</sonar.python.coverage.reportPath>
<sonar.language>py</sonar.language>
<sonar.pluginName>Python</sonar.pluginName>
<sonar.inclusions>**/*.py</sonar.inclusions>
- <!-- for JavaScaript -->
- <!--
- <sonar.language>js</sonar.language>
- <sonar.pluginName>JS</sonar.pluginName>
- <sonar.inclusions>**/*.js</sonar.inclusions>
- -->
+ <sonar.exclusions>tests/*,setup.py</sonar.exclusions>
</properties>
<build>