summaryrefslogtreecommitdiffstats
path: root/helm/setup.py
diff options
context:
space:
mode:
authorjh245g <jh245g@att.com>2018-06-27 14:50:33 -0400
committerJun (Nicolas) Hu <jh245g@att.com>2018-06-27 19:01:20 +0000
commitd9b88cc5ee987f5fed1011583a172f3c76251814 (patch)
tree36668f1ced1b3de0f13a5d6b8a90c495e032c209 /helm/setup.py
parentcec8e7c0f90be290796d9a666edeea97e118a26f (diff)
Update helm plugin source code
Change-Id: I1689d8d915c8f18a3e8230dcabb33413a2b9043e Issue-ID: CCSDK-322 Signed-off-by: jh245g <jh245g@att.com>
Diffstat (limited to 'helm/setup.py')
-rw-r--r--helm/setup.py46
1 files changed, 46 insertions, 0 deletions
diff --git a/helm/setup.py b/helm/setup.py
new file mode 100644
index 0000000..c3bfe88
--- /dev/null
+++ b/helm/setup.py
@@ -0,0 +1,46 @@
+# ============LICENSE_START==========================================
+# ===================================================================
+# Copyright (c) 2018 AT&T
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#============LICENSE_END============================================
+
+
+from setuptools import setup
+
+# Replace the place holders with values for your project
+
+setup(
+
+ # Do not use underscores in the plugin name.
+ name='onap-helm-plugin',
+ version='2.2.0',
+ author='Nicolas Hu(AT&T)',
+ author_email='jh245g@att.com',
+ description='This plugin will install/uninstall/upgrade/rollback helm charts of ONAP components. ',
+
+ # This must correspond to the actual packages in the plugin.
+ packages=['plugin'],
+
+ license='LICENSE',
+ zip_safe=False,
+ install_requires=[
+ # Necessary dependency for developing plugins, do not remove!
+ 'pyyaml>=3.12',
+ "cloudify-plugins-common>=4.1.1"
+ ],
+ test_requires=[
+ "cloudify-dsl-parser>=4.1.1"
+ "nose"
+ ]
+)