summaryrefslogtreecommitdiffstats
path: root/cds-ui/designer-client/src/app/modules/feature-modules/packages/packages-dashboard/package-list
diff options
context:
space:
mode:
authorshaaban Altanany <shaaban.eltanany.ext@orange.com>2020-01-09 10:15:28 +0200
committershaaban Altanany <shaaban.eltanany.ext@orange.com>2020-01-12 17:44:43 +0200
commitc133b83cb2cbf0b3c7a63aad105a56060db2a6df (patch)
tree6ee9d450ccfd643fa10d133bdfabeacf387186e2 /cds-ui/designer-client/src/app/modules/feature-modules/packages/packages-dashboard/package-list
parent4786e0b9ef3b4b82f4ad14bcffafa222628011d6 (diff)
creating meta data creation component(first tab)
Issue-ID: CCSDK-2014 Signed-off-by: shaaban Altanany <shaaban.eltanany.ext@orange.com> Change-Id: I35283cbb5b48174606493ecb39c20b9f717a9c06
Diffstat (limited to 'cds-ui/designer-client/src/app/modules/feature-modules/packages/packages-dashboard/package-list')
-rw-r--r--cds-ui/designer-client/src/app/modules/feature-modules/packages/packages-dashboard/package-list/package-list.component.html2
-rw-r--r--cds-ui/designer-client/src/app/modules/feature-modules/packages/packages-dashboard/package-list/package-list.component.spec.ts5
-rw-r--r--cds-ui/designer-client/src/app/modules/feature-modules/packages/packages-dashboard/package-list/package-list.component.ts4
3 files changed, 7 insertions, 4 deletions
diff --git a/cds-ui/designer-client/src/app/modules/feature-modules/packages/packages-dashboard/package-list/package-list.component.html b/cds-ui/designer-client/src/app/modules/feature-modules/packages/packages-dashboard/package-list/package-list.component.html
index 18428d4b4..8bc7adf8c 100644
--- a/cds-ui/designer-client/src/app/modules/feature-modules/packages/packages-dashboard/package-list/package-list.component.html
+++ b/cds-ui/designer-client/src/app/modules/feature-modules/packages/packages-dashboard/package-list/package-list.component.html
@@ -7,7 +7,7 @@
</div>
<div class="card-footer row">
<div class="col">
- <a href="#" role="button" aria-pressed="true" class="btn-create-package float">Create Package
+ <a href="/packages/createPackage" role="button" aria-pressed="true" class="btn-create-package float">Create Package
</a>
</div>
<div class="col">
diff --git a/cds-ui/designer-client/src/app/modules/feature-modules/packages/packages-dashboard/package-list/package-list.component.spec.ts b/cds-ui/designer-client/src/app/modules/feature-modules/packages/packages-dashboard/package-list/package-list.component.spec.ts
index f45f25996..000f9eda1 100644
--- a/cds-ui/designer-client/src/app/modules/feature-modules/packages/packages-dashboard/package-list/package-list.component.spec.ts
+++ b/cds-ui/designer-client/src/app/modules/feature-modules/packages/packages-dashboard/package-list/package-list.component.spec.ts
@@ -4,6 +4,7 @@ import { PackageListComponent } from './package-list.component';
import { PackagesStore } from '../../packages.store';
import { getBluePrintPageMock } from '../../blueprint.page.mock';
import { of } from 'rxjs';
+import {PackagesDashboardState} from '../../model/packages-dashboard.state';
describe('PackageListComponent', () => {
let component: PackageListComponent;
@@ -12,7 +13,9 @@ describe('PackageListComponent', () => {
beforeEach(async(() => {
- store = { state$: of(getBluePrintPageMock()) };
+ const dashBoard = new PackagesDashboardState();
+ dashBoard.page = getBluePrintPageMock();
+ store = { state$: of(dashBoard) };
TestBed.configureTestingModule({
declarations: [ PackageListComponent ],
diff --git a/cds-ui/designer-client/src/app/modules/feature-modules/packages/packages-dashboard/package-list/package-list.component.ts b/cds-ui/designer-client/src/app/modules/feature-modules/packages/packages-dashboard/package-list/package-list.component.ts
index c7ec0af20..049801227 100644
--- a/cds-ui/designer-client/src/app/modules/feature-modules/packages/packages-dashboard/package-list/package-list.component.ts
+++ b/cds-ui/designer-client/src/app/modules/feature-modules/packages/packages-dashboard/package-list/package-list.component.ts
@@ -16,8 +16,8 @@ export class PackageListComponent implements OnInit {
console.log('PackageListComponent');
this.packagesStore.state$.subscribe(state => {
console.log(state);
- if (state.page) {
- this.viewedPackages = state.page.content;
+ if (state.filteredPackages) {
+ this.viewedPackages = state.filteredPackages.content;
}
});
}