aboutsummaryrefslogtreecommitdiffstats
path: root/test/mocks/mass-pnf-sim/setup.py
diff options
context:
space:
mode:
authorEli Halych <illia.halych@t-mobile.pl>2020-11-24 09:59:07 +0000
committerEli Halych <illia.halych@t-mobile.pl>2020-11-24 10:14:45 +0000
commitdcccf6e2c90ef7b079ac6a4f6258b7d550fa79c5 (patch)
tree4d24f92105fb4142bda28d5637636dee41cef9b3 /test/mocks/mass-pnf-sim/setup.py
parent6b92f67b5c2e41dfe6272f401989d17c7452c089 (diff)
Change mass-pnf-sim folder name to masspnfsim
Details: - Allows for importing python files/classes/methods via normal import. - Dashes in mass-pnf-sim prevented from a normal Python import. - mass-pnf-sim path referenced in the project files changed to masspnfsim. - Possibility of using masspnfsim as a git submodule that requires noraml import. Issue-ID: INT-1789 Signed-off-by: Eli Halych <illia.halych@t-mobile.pl> Change-Id: I00cd753181c9b240b99881057cf777cf7977387a
Diffstat (limited to 'test/mocks/mass-pnf-sim/setup.py')
-rwxr-xr-xtest/mocks/mass-pnf-sim/setup.py38
1 files changed, 0 insertions, 38 deletions
diff --git a/test/mocks/mass-pnf-sim/setup.py b/test/mocks/mass-pnf-sim/setup.py
deleted file mode 100755
index 99d722ca5..000000000
--- a/test/mocks/mass-pnf-sim/setup.py
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/usr/bin/env python3
-
-# COPYRIGHT NOTICE STARTS HERE
-#
-# Copyright 2020 Samsung Electronics Co., Ltd.
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-#
-# COPYRIGHT NOTICE ENDS HERE
-
-# This file is only meant to be a single source of truth for package
-# dependencies. It's consumed by bin/setup.sh and tox hence shouldn't
-# be run directly for package builds as currently vcpe scripts are not
-# provided as a python package.
-
-import setuptools
-
-# Define MassPnfSim module dependencies below
-setuptools.setup(
- name="MassPnfSim",
- install_requires=[
- 'argparse',
- 'ipaddress',
- 'requests',
- 'pyyaml',
- 'docker'
- ]
-)