summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 9 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index 85e74ba..73e1c1a 100644
--- a/setup.py
+++ b/setup.py
@@ -1,8 +1,5 @@
-"""package for policy-handler of DCAE-Controller"""
-
-# org.onap.dcae
# ================================================================================
-# Copyright (c) 2017 AT&T Intellectual Property. All rights reserved.
+# Copyright (c) 2017-2018 AT&T Intellectual Property. All rights reserved.
# ================================================================================
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -19,27 +16,25 @@
#
# ECOMP is a trademark and service mark of AT&T Intellectual Property.
+"""package for policy-handler of DCAE-Controller"""
+
from setuptools import setup
setup(
name='policyhandler',
description='DCAE-Controller policy-handler to communicate with policy-engine',
- version="1.0.0",
+ version="3.0.1",
author='Alex Shatov',
packages=['policyhandler'],
zip_safe=False,
install_requires=[
- "CherryPy>=10.2.2,<11.0",
- "enum34>=1.1.6",
- "future>=0.16.0",
- "requests>=2.13.0,<3.0.0",
- "six>=1.10.0",
- "websocket-client>=0.40.0"
+ "CherryPy>=15.0.0,<16.0.0",
+ "psutil>=5.4.5,<6.0.0",
+ "requests>=2.18.4,<3.0.0",
+ "websocket-client>=0.48.0,<1.0.0"
],
keywords='policy dcae controller',
classifiers=[
- 'Development Status :: 4 - Beta',
- 'Intended Audience :: Developers',
- 'Programming Language :: Python :: 2.7'
+ 'Programming Language :: Python :: 3.6'
]
)